Page 1 of 1

Faulty FF, or just me?

Posted: Thu Nov 23, 2017 9:19 pm
by TBreezy
Hey guys. Can anyone confirm that this is a faulty unit? It's chopping and changing between depths and lagging on screen. Won't show a depth reading.

It's 3 months old and I have used it maybe 4 times. It was working great to begin with. In the last month I haven't used it at all but noticed this on Tuesday. Thought it was a flat battery, but running another test tonight yields the same result.

Lowrance Hook 3x. I did the transducer mounting with silicone. Have pulled it out and there's nothing weird about the mount.

I have googled but there's not a hell of a lot of info to find on this model and can't even find instructions for a hard/soft reset. I did discover a lot of people have problems with Lowrance units though.

Perhaps it's due to the fact that it is a cheap unit, which sucks because for some of us, that's our only price range.

Has anyone else experienced this issue with other units? Or issues with this particular unit?

Thanks guys.
ff.JPG

Re: Faulty FF, or just me?

Posted: Fri Nov 24, 2017 6:36 am
by Hairy Little Dwarf
Try holding the + and - keys while powering up, then release after a couple of seconds, may have to try different timings , eg instant, 1s, 2s etc
Wild guess based on my Lowrance.

Can you try it on someone elses rig?

Re: Faulty FF, or just me?

Posted: Fri Nov 24, 2017 7:04 am
by TBreezy
Cool, will do. Thanks.

I don’t know anyone else with a transducer that I could try it out on unfortunately.

I have emailed the place I bought it from so I guess I’ll wait to see what they say.

Looks like I’ll be fishing old school this weekend!

Re: Faulty FF, or just me?

Posted: Fri Nov 24, 2017 7:18 am
by Hairy Little Dwarf
At least you've still got the warranty to fall back on. :y:

Re: Faulty FF, or just me?

Posted: Fri Nov 24, 2017 7:53 am
by Hainesy
Drop Pointloader here on the Forum a message as he might be able to offer some suggestions

Re: Faulty FF, or just me?

Posted: Sat Nov 25, 2017 8:07 am
by woodstock
Check if transducer making ticking sound if not could be faulty.If ticking I would try going out for paddle to about 10 meters and put transducer in water to see if will works (you could have air bubbles in silicone)
If still not working return it and buy a new hook2 4 due in stores December

Sent from my SM-T110 using Tapatalk


Re: Faulty FF, or just me?

Posted: Sun Nov 26, 2017 4:58 pm
by TBreezy
woodstock wrote:
Sat Nov 25, 2017 8:07 am
Check if transducer making ticking sound if not could be faulty.If ticking I would try going out for paddle to about 10 meters and put transducer in water to see if will works (you could have air bubbles in silicone)
If still not working return it and buy a new hook2 4 due in stores December

Sent from my SM-T110 using Tapatalk
No ticking. I reckon it's faulty. I have ripped everything out and put it back in the box to send it back. Didn't see any air bubbles in the silicone so glad I didn't f*#k that up!

You reckon those new ones are better?

Re: Faulty FF, or just me?

Posted: Sun Nov 26, 2017 8:00 pm
by woodstock
TBreezy wrote:
woodstock wrote:
Sat Nov 25, 2017 8:07 am
Check if transducer making ticking sound if not could be faulty.If ticking I would try going out for paddle to about 10 meters and put transducer in water to see if will works (you could have air bubbles in silicone)
If still not working return it and buy a new hook2 4 due in stores December

Sent from my SM-T110 using Tapatalk
No ticking. I reckon it's faulty. I have ripped everything out and put it back in the box to send it back. Didn't see any air bubbles in the silicone so glad I didn't f*#k that up!

You reckon those new ones are better?
Yes hook2 4x better unit or go with garmin striker 4

Sent from my SM-T110 using Tapatalk


Re: Faulty FF, or just me?

Posted: Sun Nov 26, 2017 10:21 pm
by TBreezy
Thanks guys.

Re: Faulty FF, or just me?

Posted: Tue Jul 30, 2019 8:10 am
by dedant
I’ve taken my 7X HOOK2 off the stealth before I sold it due to the thing showing the screen like that. Even tried it off the wharf with the transducer on a stick , no better. It’s never worked properly since the first time I used it. Marine Deals have $600 off me for nothing but an expensive box that is sitting on a shelf. I’ll never buy a lowrance again, and not from Marine Deals either, they’ve looked at it once and said there was nothing wrong,but I did have to replace the power cable after the fourth time out with it.

Re: Faulty FF, or just me?

Posted: Tue Jul 30, 2019 10:27 pm
by sk8e8
dedant wrote:
Tue Jul 30, 2019 8:10 am
I’ve taken my 7X HOOK2 off the stealth before I sold it due to the thing showing the screen like that. Even tried it off the wharf with the transducer on a stick , no better. It’s never worked properly since the first time I used it. Marine Deals have $600 off me for nothing but an expensive box that is sitting on a shelf. I’ll never buy a lowrance again, and not from Marine Deals either, they’ve looked at it once and said there was nothing wrong,but I did have to replace the power cable after the fourth time out with it.
I'm not running a Lowrance at the moment, but I always found their service and support excellent, even outside of warranty.