Elite 7 - issues help please

Discuss anything electronic or electrical, lights, sounders, GPS etc..
Post Reply
leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Tue Jan 03, 2017 6:11 pm

Hi guys I have an Elite 7 Chirp that i really could do with some help with. Over the last week I had some minor display issues with it I did a hard reset and now I cant load anything from the card reader (Navionics or the latest update from Lowrance) and the GPS refuses to get a signal / fix even when given and hour in clear sky. whenever i try to browse titles on the card or load up navionics i get (no cards ready), very frustrated would be good to get some advice from the experience here. (currently running version 4.0.5.1.13) cheers

Fisho91
Posts: 36
Joined: Sun Oct 30, 2016 7:36 pm
Kayak Make: Viking
Kayak Model: Profiseh 400
Location: Hawkes Bay

Tue Jan 03, 2017 7:58 pm

Any corrosion on plugs in the back?
Or in sd card slot?
Good battery voltage?

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Tue Jan 03, 2017 8:09 pm

Hi Fisho91, no corrosion on any of the rear plugs or cables, i cant see any obstructions or corrosion in the sd card slot, battery voltage is good, recently new SLA 12v - 9ah battery charged properly. I found another website that suggested trying to install updates via sd card as a solution to GPS issue, by pressing start while holding the pages button down to force the boot from the sd card but this didn't work either. really stumped with this and hanging to get back on the water. cheers

User avatar
Hairy Little Dwarf
Moderator
Posts: 6998
Joined: Thu Oct 16, 2008 9:39 am
Kayak Make: Phoenix
Kayak Model: Hornet

Tue Jan 03, 2017 9:15 pm

I don't know the machine, but when doing the factory reset, have you inadvertently disabled GPS and defaulted to internal memory rather than SD?
(I know it's not likely, but...)
Image
.................... "Flying Mango".......... [Up for sale, $1400]

Phoenix Hornet - Specialty Assault Craft

Dad! Dad! Look at his fish! It's way bigger than anything you've EVER caught! - Nosey 7-8yo boy on opening my icebox to father strapping down his $XXX Stabicraft 759(?) - Gold. Pure Gold.

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Tue Jan 03, 2017 9:30 pm

Have you downloaded software update on blank sd card from lowrance nz website.To do update remove navionics sd card and put in blank sd card with software update and push Power button only .
I would first go in menu go to systems and go to restore defaults and reset once you have done this you will have go into charts menu and select. navionics .
I did a software update on elite 4 and unit would not read navionics card so did restore defaults and fixed problem

Sent from my SM-T110 using Tapatalk

Oldspice
Posts: 55
Joined: Sun Aug 10, 2014 10:22 pm
Kayak Make: ocean kayak
Kayak Model: prowler ultra 4.7
Location: Auckland

Tue Jan 03, 2017 10:35 pm

Hey HLD, Thats a good point about disabling GPS, will check those settings tomorow when battery is charged again.
Hey woodstock, I downloaded the update on a blank sd card, turned off the unit installed the card pressed power, no indication of update like in the video and when checking the version in settings menu no change. Will try the restore.settings as you suggested tomorow. So frustrating i like my gear 100% and this really messes with my mojo.

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Tue Jan 03, 2017 10:43 pm

sorry HLD and Woodstock previous reply was from me, shared computer pain in the ass.

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Wed Jan 04, 2017 8:52 am

software updates are n zip file need to unzip before putting on SD card.If you don't unzip file elite 7 won't read updates

Sent from my SM-J200Y using Tapatalk

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Wed Jan 04, 2017 9:46 am

Hey woodstock yip unzipped and only had the upd file on he sd card: didnt read it. Tryed HLD suggestion about making sure the gps was on : tryed outside with gps settings on auto for 20mins then with back on to elite 7 display: no connection to satelite. Tryed your suggestion about running update then restore: no go either. Current state sitting on window sill of large open window running trying to get fix doing my best to keep ratbag kids away from the power cable. Seriosuly stumped with this. Wonder if theres any lowrance guru in papakura that could have a look at it?

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Wed Jan 04, 2017 8:51 pm

Image

Go in system menu go to gas hit enter and see if setting match photo

Sometimes it can take 6 times turning unit off/on before unit will read so card update

Sent from my SM-T110 using Tapatalk


leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Wed Jan 04, 2017 9:56 pm

oki doki mate will try that now thanks, repost later results ..many thanks

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Wed Jan 04, 2017 10:19 pm

hey woodstock,
tried the rebooting with the sd update card in ten times - no go. had a look at gps photo of view i see attached.
Attachments
20170104_220354.jpg
20170104_220354.jpg (101.72 KiB) Viewed 1916 times

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Wed Jan 04, 2017 10:48 pm

Might need to give tech guys at navico a call
Call toll free within New Zealand 0800 4 NAVICO (0800 462 8426)

Sent from my SM-T110 using Tapatalk

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Thu Jan 05, 2017 1:11 am

Cheers for the number will try in the morning. Got reply from lowrance: warranty expired sounds like an internal issue only solution is to buy a new model.

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Thu Jan 05, 2017 5:51 pm

Bugger how old was the unit

Sent from my SM-T110 using Tapatalk

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Thu Jan 05, 2017 7:05 pm

hey man, 2 years old, i brought it second hand, worked for one trip then all of this.
My father in law just put the final nail in the coffin, thought a boaty of 45 odd years experience would have some guru trick, he took it into his shed when we visited while i was having a coffee came back 20mins later - nah no good mate!. he unscrewed the rear of the unit, sprayed the shit out of the internals with contact cleaner then used a power drill to screw the unit up again - in doing so cracked the housing around the screws in 5 places and ruining the screen with big shade and flare stains. now when i contacted the tech support this afternoon they said i was within the 5 year service plan and would be eligible for a heavily discounted new replacement unit, now not valid thanks to aforementioned father in law. wicked!
thanks for the help woodstock, im still looking for a solution, the unit still runs, the screen is very stained, the housing cracked and the sd card wont read and GPS still doesnt work, it would be good if someone did repairs, but it doesn't look like people do that for these units. having all the damage done to it now i dont really have that many options.

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Fri Jan 06, 2017 12:01 pm

Maybe buy Hook 4x so you have a less got a fish finder and the old cables from elite 7 will fit it.Nice having a big screen but hurts the wallet when it shits itself :-(

Sent from my SM-T110 using Tapatalk

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Fri Jan 06, 2017 1:48 pm

hey woodstock, that may be what i do in the long run but now I'm sh*t broke, pretty depressed about the whole situation, and back to work in a few days, Ive thrown it on trade-me been as honest as possible and will continue to explore repair options, who knows i might start it up and boom all fixed.....lol cheers for all the advice - thanks

User avatar
woodstock
Posts: 148
Joined: Sun May 15, 2011 10:41 am
Kayak Make: viking
Kayak Model: profish 400
Location: Tindalls bay

Fri Jan 06, 2017 5:00 pm

Get out on kayak catch a fish or two maybe PB will cheer you up :-)

Sent from my SM-T110 using Tapatalk

leaf on the wind
Posts: 15
Joined: Tue Jan 03, 2017 1:44 pm
Kayak Make: OK
Kayak Model: Ultra 4.3
Location: Auckland

Fri Feb 03, 2017 3:20 pm

Righty-O
after some time back at work i started trying to rebuild the Elite 7 fish finder smashed up by the father in law.
end-state now the fish finder works 100% so absolutely happy as about that. (thanks for all the help those of you that replied)
some of the repairs i made, Ribbon wires from motherboard to GPS antenna had a partial tear so repaired that, connection from sd card reader to the motherboard had corrosion on the terminals, this took ages to clean away with a magnifying glass, fine mascara brush from the wife, finally cleaned up and coated with dielectric grease worked a treat, expoxy clear glued the cracks around the housing inside and out. Of note to other Elite 7 owners (possibly) i noticed some fine cracks inside the rear housing were the gimble nuts screw in, only under a magnifying glass could i see the hairline cracks in the outer housing, (you know in just the right light) so now transducer mounted again, power hooked up and ready to hit the waves. so a happy result in the end, i have the industrial sewing machine out now making a custom cover, kinda paranoid about electrics now. cheers all for the help.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests